Help

System Requirements

Talky uses a cutting edge technology called WebRTC that is only available in Chrome, Firefox, Opera, Safari, and Edge. Please make sure that your browser is updated to the latest version available for the best performance.

Android users can use Talky in a compatible browser. iPhone and iPad users, check out our iOS app.